博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDU 1505 City Game 矩阵的最大面积
阅读量:5291 次
发布时间:2019-06-14

本文共 3017 字,大约阅读时间需要 10 分钟。

City Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2512    Accepted Submission(s): 1016

Problem Description
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.
Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.
Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.
 

 

Input
The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:
R – reserved unit
F – free unit
In the end of each area description there is a separating line.
 

 

Output
For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.
 

 

Sample Input
2 5 6 R F F F F F F F F F F F R R R F F F F F F F F F F F F F F F 5 5 R R R R R R R R R R R R R R R R R R R R R R R R R
 

 

Sample Output
45 0
 
思路:子矩阵1506的加强版,将一维的状态转换为二维的状态,即再上一基础上加以个for循环,并且R置为F时置为在前行的基础上+1,求出最大面积。
 
代码:

#include<stdio.h>

#include<string.h>
#define MX(a,b)  (a>b?a:b)
#define N 1005
int f[N][N],l[N],r[N];
int n,m;
char s[5];
int max;

int main()

{
   int t;
   scanf("%d",&t);
   while(t--)
   {
     memset(f,0,sizeof(f));
  scanf("%d%d",&n,&m);
  for(int i=1;i<=n;i++)
  {
     for(int j=1;j<=m;j++)
  {
       scanf("%s",s);
    if(s[0]=='F')
    f[i][j]=f[i-1][j]+1;    
     }   
     }   
      max=0;
     int temp;
     for(int k=1;k<=n;k++)

   {    

     for(int i=1;i<=m;i++)
     l[i]=r[i]=i;
  for(int i=2;i<=m;i++)
  {
     temp=l[i];
     while(f[k][temp-1]>=f[k][i]&&temp>1)
     temp=l[temp-1];
     l[i]=temp;   
     }
  for(int i=m-1;i>=1;i--)
  {
    temp=r[i];
    while(f[k][temp+1]>=f[k][i]&&temp<n)
    temp=r[temp+1];
    r[i]=temp;   
     } 
  for(int i=1;i<=m;i++)
  max=MX(max,(r[i]-l[i]+1)*f[k][i]); 
     }
     printf("%d\n",max*3);
   }  
   return 0;
}

链接:

转载于:https://www.cnblogs.com/hebozi/archive/2012/08/10/2633102.html

你可能感兴趣的文章
HIVE快速入门 分类: B4_HIVE 2015-...
查看>>
Mysql安装方法及安装问题解决
查看>>
Java动态代理的两种实现方式:
查看>>
PHP trait
查看>>
Redis的常用命令(三)
查看>>
HDOJ 4749 Parade Show
查看>>
python 多线程并发threading & 任务队列Queue
查看>>
【黑马程序员】资深程序员的见解
查看>>
1_fbauto
查看>>
IO体系、集合体系、多线程、jdbc
查看>>
Service Bus Namespace 和 Access Control
查看>>
关于时间:UTC/GMT/xST/ xDT
查看>>
[51Nod1089] 最长回文子串 V2(Manacher算法)
查看>>
Asp.Net生命周期系列六
查看>>
php引用 =& 详解
查看>>
面向对象思想
查看>>
查看数据是否启动
查看>>
如何正确的完全卸载MySQL
查看>>
Codeforces 914D Bash and a Tough Math Puzzle (ZKW线段树)
查看>>
static使用方法小结
查看>>